Check your browser: FAST Tester requires the use of Google chrome browser